Search engine issues
Incident Report for ACT Academy
Resolved
We have restarted our search engine and the site is operating normally.
Posted over 4 years ago. Jan 29, 2015 - 09:24 PST
Investigating
We're investigating an issue with our search engine
Posted over 4 years ago. Jan 29, 2015 - 09:06 PST