https://www.opened.com slow load times
Incident Report for ACT Academy
Resolved
Response times are back to normal.
Posted almost 4 years ago. Sep 23, 2015 - 10:47 PDT
Monitoring
Site performance is improving and most pages are loading now. We will keep this incident open until load times are back to normal.
Posted almost 4 years ago. Sep 23, 2015 - 10:06 PDT
Identified
We have identified an issue with our upstream provider that is causing slow or unresponsive loading of https://www.opened.com. We will update here as we make progress addressing the issue.
Posted almost 4 years ago. Sep 23, 2015 - 09:40 PDT